1038 Recover the Smallest Number (30 point(s))

1038 Recover the Smallest Number (30 point(s))

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

思想:贪心策略 

题意:存在一组可能含有前导0的数字串,请问如何连接使得它的值尽可能的小。

由样例可以看出,不能直接排序并连接,如32、321中应当32132<32321,可以看出两个字符串之间的排序应当取决于它们拼接后的大小。采用这样一种贪心策略:对于S1 与 S2,如果 S1+S2 < S2 + S1,那么把 S1放在S2前面。将上述写到cmp函数中。

注意点:前导0的处理。

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
bool cmp(string a,string b){
	return a+b<b+a;
}
vector<string> s;
int main(void){
	int n;string str,ans;
	cin>>n;
	while(n--){
		cin>>str;
		s.push_back(str);
	}
	sort(s.begin(),s.end(),cmp);
	for(int i=0;i<s.size();i++) ans+=s[i];
	while(ans.size()>0&&ans[0]=='0') ans.erase(ans.begin());
	if(ans.size()==0) cout<<"0"<<endl;
	else cout<<ans<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值