E - Team Queue

Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0
Sample Output
Scenario #1
101
102
103
201
202
203
Scenario #2
259001
259002
259003
259004
259005
260001


#include<stdio.h>
#include<string.h>
#include<map>
#include<cstdio>
#include<queue>
#include<algorithm>
const int N =1010;
using namespace std;
int main()
{
    int t,kase=0;
    freopen("1.txt","r",stdin);
    while(scanf("%d",&t)==1&&t)
    {
        printf("Scenario #%d\n",++kase);map<int,int>team;
        for(int i=0;i<t;i++)
        {

            int n,x;scanf("%d",&n);
            while(n--){scanf("%d",&x);team[x]=i;}
        }
        queue<int>q,q2[N];
        for(;;)
        {
            int x;char cmd[10];
            scanf("%s",cmd);
            if(cmd[0]=='S')break;
            else if(cmd[0]=='D'){                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
                int t=q.front();
                printf("%d\n",q2[t].front());q2[t].pop();
                if(q2[t].empty())q.pop();
            }
            else if(cmd[0]=='E'){
                scanf("%d",&x);
                int t=team[x];
                if(q2[t].empty())q.push(t);
                q2[t].push(x);
            }
        }
        printf("\n");
    }
}
每个实例的第二,第三行是告诉你一个那些人组成一个队,第一个数据告诉我们有几个团队构成一个新的队列;而执行命令时要在新开的队列进行插入和删除,而不是在原来map的基础上进行,map只是为了告诉我们在对队列进行操作时哪些人是一个团队的


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值