E - XYZZY HDU - 1317 bellman

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.
Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.
Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".
Sample Input
5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1
Sample Output
hopeless
hopeless
winnable
winnable  
题意是指 从1 到 N 能否保证 到达每个点的时候 能量都为正数。
分析;分为两种情况,当图中存在正权环时并N也在环中时必定满足条件,而不在时正权环时,应和无环的情况归结为一种,当无环时直接bellman-wall
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#define INF -0xffffff
using namespace std;
struct Edge{int x,y;}edge[20000];
int arrive[103][103],N;
int energy[103],dist[103];
void floyd()
{
    for(int k=1;k<=N;k++)
    {
        for(int i=1;i<=N;i++)
        {
            for(int j=1;j<=N;j++)
                arrive[i][j]=arrive[i][j]||(arrive[i][k]&&arrive[k][j]);
        }
    }
}
void bellman(int T)
{
    for(int i=1;i<=N;i++)dist[i]=INF;
    dist[1]=100;
    for(int i=1;i<N;i++)
    {
        for(int j=1;j<=T;j++)
        {
            int st=edge[j].x;
            int en=edge[j].y;
            if(dist[en]<energy[en]+dist[st]&&energy[en]+dist[st]>0)dist[en]=energy[en]+dist[st];
        }
    }
    bool vs=false;
    for(int i=1;i<=T;i++)//判断是否存在环
    {
        int st=edge[i].x;int en=edge[i].y;
        if(dist[en]<energy[en]+dist[st]&&energy[en]+dist[st]>0&&arrive[en][N])//arrive[en][N]表示N在环中
        {
            printf("winnable\n");vs=true;break;
        }
    }
    if(!vs)
    {
        if(dist[N]>0)printf("winnable\n");
        else printf("hopeless\n");
    }
}
int main()
{
    while(scanf("%d",&N)&&N!=-1)
    {
        memset(arrive,0,sizeof(arrive));
        for(int i=1;i<=N;i++)arrive[i][i]=1;
        int sum=0;
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&energy[i]);int num;scanf("%d",&num);
            for(int j=0;j<num;j++)
            {
                sum++;
                int x;scanf("%d",&x);
                edge[sum].x=i;edge[sum].y=x;
                arrive[i][x]=1;
            }
        }
        floyd();
        bellman(sum);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值