G - In Action HDU - 3339 floyd

 
 
  Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.  Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.  But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station, we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.  Now our commander wants to know the minimal oil cost in this action.
Input
The first line of the input contains a single integer T, specifying the number of testcase in the file.  For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction).  Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.  Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.
Output
The minimal oil cost in this action.  If not exist print "impossible"(without quotes).
Sample Input
2
2 3
0 2 9
2 1 3
1 0 2
1
3
2 1
2 1 3
1
3
Sample Output
5
impossible

有一个坦克基地标为0,有1-n个电站,每个电站都有相应的能量,现在从0出发取占领电站获取她们的能量,当获取的能量不少于总能量的一半时完成任务,
给你m条路,每条路连接两个地点,现在求用最少的路径完成任务;(比较容易忽视的是,每辆坦克一旦选择占领某地就要停在那里,不能继续占领,
即要不断从坦克基地出发坦克,之前没注意到这点,只用了一辆坦克去不断占领,果断wa了)另外这里还需要用到dp的思想,用最少的油来获得最多的的能源;将0到所有的点的最短路径之和作为背包的容量,而获得的能源视为价值



#include <iostream>
#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;
int n,m;
int a[110][110];
int energy[110];

int dp[10100];
void floyd()
{

    for(int k=0;k<=n;k++)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                if(a[i][j]>a[i][k]+a[k][j])a[i][j]=a[i][k]+a[k][j];
            }
        }
    }
}
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        ///memset(a,INF,sizeof(a));
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                a[i][j]=INF;
            }
            a[i][i]=0;
        }
        for(int i=0;i<m;i++)
        {
            int x,y,w;scanf("%d%d%d",&x,&y,&w);
            if(w<a[x][y])a[y][x]=a[x][y]=w;

        }
        int sum=0;floyd();int len=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&energy[i]);sum+=energy[i];
            if(a[0][i]!=INF)len+=a[0][i];
        }

        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=len;j>=a[0][i];j--)
            {
                if(dp[j-a[0][i]]+energy[i]>dp[j])
                    dp[j]=dp[j-a[0][i]]+energy[i];
            }
        }
        bool  vs=false;
        for(int i=1;i<=len;i++)
        {
            if(dp[i]>sum/2.0)
                {printf("%d\n",i);vs=true;break;}
        }
        if(!vs)printf("impossible\n");

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值