C - Humble Numbers HDU - 1058

题意:输出第n个因子全由2,3,5,7中的数组成的数
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
#include<stdio.h>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN=5844;
long long a[MAXN];
int main()
{
    priority_queue<long long, vector<long long>, greater<long long> >it;
    int i=1;memset(a,0,sizeof(a));
    while(i<=5842){
        it.push(1);
        while(1){
            if(i>5842)break;
            long long j=it.top();it.pop();
            if(a[i-1]!=j)
            {
                 a[i]=j;
                it.push(j*2);
                it.push(j*3);
               it.push(j*5);
               it.push(j*7);
               i++;
            }

        }

    }
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        else
        {
            if(n%10==1&&n%100!=11)
                printf("The %dst humble number is %d.\n",n,a[n]);
            else if(n%10==2&&n%100!=12)
                printf("The %dnd humble number is %d.\n",n,a[n]);
            else if(n%10==3&&n%100!=13)
                printf("The %drd humble number is %d.\n",n,a[n]);
            else
                printf("The %dth humble number is %d.\n",n,a[n]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值