Counting Triangles

Given an equilateral triangle with n the length of its side, program to count how many triangles in it. 
 


 

 

Input

The length n (n <= 500) of the equilateral triangle's side, one per line. 

process to the end of the file 

 

Output

The number of triangles in the equilateral triangle, one per line. 

 

Sample Input

1 2 3

Sample Output

1 5 13

求一个边长为n的正三角形里有多少正三角形,递推。n每加一,
增加的三角形都是最下面那一条线上的正三角和
倒三角之和,其中的正三角就是在最下面的边(一共n+1个点)
中选两个点作为三角形的两个点即是C(n+1,2),而
对于倒三角,就只有一个点在最下面的边上,通过画图发现,
除了最左右两个点不能构成倒三角,其他的点能构成倒三角的
数量从左向中间递增,然后递减。其中当n为奇数时有两个点
可作为中间点,即倒三角为1+2+....+(n-1)/2+(n-1)/2+...2+1个,
当n为偶数时,只有唯一的点作为中间点,即倒三角的个数为1+2+...+n/2+..+2+1

#include <iostream>
 
using namespace std;
 
int main()
{
    int i,n;
    __int64 a[501] = {0,1};
    for(i=2; i<501; i++)
    {
        if(i % 2== 0)
        {
            a[i] = a[i-1] + i*(i+1)/2 + i*i/4;
        }
        else
            a[i] = a[i-1] + i*(i+1)/2 + (i*i-1)/4;
    }
    while(cin>>n)
    {
        cout<<a[n]<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值