D - Sigma Function LightOJ - 1336

链接lightoj1336

Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is

Then we can write,

For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value of σ.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output

For each case, print the case number and the result.

Sample Input

4

3

10

100

1000

Sample Output

Case 1: 1

Case 2: 5

Case 3: 83

Case 4: 947

由算术基本定理可以得出当ei全为偶数时,因子和为奇数。满足条件的可以发现是完全平方数。设这个数为x,我们可以发现2*x也满足条件。原因如下,x的因子和为奇数,2*x或2的n次方*x在σ(n)  函数上乘(1+2的1次+2的2次+...+2的n次)一定为一个奇数,故1-n中所有的因子和为奇数的数为完全平方数及其2倍的个数。

code:

#include<bits/stdc++.h>
using namespace std;
int main()
{
   int T,a;
   long long n;
   scanf("%d",&T);
  for(int c=1;c<=T;c++)
   {
       scanf("%lld",&n);
       a=(int)sqrt(n)+(int)sqrt(n/2);  //sqrt(n)完全平方数个数  sqrt(n/2)2*完全平方数且小于n的个数
       printf("Case %d: %lld\n",c,n-a);
   }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值