E - Leading and Trailing LightOJ - 1282

题目链接点击打开链接

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669


题意,求出n的k次幂前三位和后三位。

后三位由快速幂,前三位可由数学公式推导。

n的k次幂我们用科学记数法表示则a*10的m次方,两边同时取对数

得k*log10(n)=log10(a)+m。这里可以发现m为k*log10(n)得整数部分(因为a大于0小于10,取对数后为0.xxx形式),

所以可求得log10(a),这里求前三位故加2(相当于乘100),算10得次方既可。

code:

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define mod 1000
LL quick_pow(LL x,int k)
{
    LL ans=1;
    while(k>0)
    {
        if(k&1)
        {
            ans*=x;
            ans%=mod;
        }
        x*=x;
        x%=mod;
        k>>=1;
    }
    return ans;
}


int main()
{
    int T;
    scanf("%d",&T);
    for(int c= 1; c<=T; c++)
    {
        int k,i;
        LL n;
        scanf("%lld %d",&n,&k);
        double temp=k*log10(n);
       temp=fmod(temp,1);
       int res=(int)(pow(10,temp)*100);
        printf("Case %d: %03d %03lld\n",c,res,quick_pow(n,k));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值