The MAX HDU - 2803

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.

Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2….Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
Output
For each test case, output the biggest value of F you can find on a line.
Sample Input
2
1 2
0
Sample Output
4017

题解:先看一个例子:
若V1=2,V2=3.《1》F=2*1+3*2018;《2》F=2*2+3*2017=2*(1+1)+3*(2018-1)=2*1+3*2018+2-3;
很显然只需要让最大的V与最大的X相乘即可,其余的分配与1相乘。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
    ll n;
    ll a[105];
    while(scanf("%lld",&n)&&n){
        for(ll i=0;i<n;i++)
            scanf("%lld",&a[i]);
        sort(a,a+n);
        ll res=0;
        res=a[n-1]*(2009-n+1);
        for(ll i=0;i<n-1;i++)
            res+=a[i];
        printf("%lld\n",res);

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值