HDU1814 Peaceful Commission —— 2-sat 染色法

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1814


Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4142    Accepted Submission(s): 1383


Problem Description
The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others. 

The Commission has to fulfill the following conditions: 
1.Each party has exactly one representative in the Commission, 
2.If two deputies do not like each other, they cannot both belong to the Commission. 

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party . 

Task 
Write a program, which: 
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms, 
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members, 
3.writes the result in the text file SPO.OUT. 
 

Input
In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other. 
There are multiple test cases. Process to end of file. 
 

Output
The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence. 
 

Sample Input
  
  
3 2 1 3 2 4
 

Sample Output
  
  
1 4 5
 

Source




代码如下:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const int mod = 1e9+7;
const int MAXN = 2e4+10;

struct Edge
{
    int to, next;
}edge[MAXN<<1];
int head[MAXN], tot;

void init()
{
    tot = 0;
    memset(head, -1, sizeof(head));
}

void add(int u, int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}

bool vis[MAXN];
int S[MAXN], top;
bool dfs(int u)
{
    if(vis[u^1]) return false;  //如果u的对方被选了, 则冲突
    if(vis[u]) return true;     //u已选,则直接return true;
    vis[u] = true;  //选中u
    S[top++] = u;   //u入栈
    for(int i = head[u]; i!=-1; i=edge[i].next) //遍历与u相邻的点
        if(!dfs(edge[i].to))
            return false;
    return true;
}

bool Twosat(int n)
{
    memset(vis,0,sizeof(vis));
    for(int i = 0; i<n; i+=2)
    {
        if(vis[i]||vis[i^1]) continue;  
        top = 0;
        if(!dfs(i)) //以i出发失败
        {
            while(top) vis[S[--top]] = false;   //把之前入栈的元素全部置为未选中
            if(!dfs(i^1)) return false;     //并尝试以i^1出发,如果也失败,则没有解决方案。因为一对中必须选一个。
        }
    }
    return true;
}


int main()
{
    int n, m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        for(int i = 0; i<m; i++)
        {
            int u, v;
            scanf("%d%d",&u,&v);
            u--; v--;   //小标从0开始,使得(i,i^1)为一对
            add(u, v^1);  //u和v有冲突, 则u连v^1,下同
            add(v, u^1);
        }

        if(Twosat(2*n))
        {
            for(int i = 0; i<2*n; i++)
                if(vis[i])
                    printf("%d\n", i+1);
        }
        else printf("NIE\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值