E - Internet Service Providers

E - Internet Service Providers

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status
Description
A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the N ISPs can get from using the channel. Notice that N, C, T, and the optimal T are integer numbers.

Input
Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output
For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input
6
1 0
0 1
4 3
2 8
3 27
25 1000000000
Sample Output
Case 1: 0
Case 2: 0
Case 3: 0
Case 4: 2
Case 5: 4
Case 6: 20000000


  1. 题意:求二次方程最大值时x的最小值,x为整数。
  2. 思路:图像法:由实数范围内的二次方程判断,由 (0 ≤ N, C ≤ 109),图像开口向下,取得最大值处为-b/2a,求导也可推出。
  3. 失误:写了一遍,测试数据时有错误,经检验没考虑n=0的情况,又看了一边题,有看错了t的范围;最后还应考虑t<=c但-c/2n
#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    __int64 t,n,c,x,k=0;
    cin>>t;

    while(t--)
    {
        cin>>n>>c;

        cout<<"Case "<<++k<<": ";

        if(n==0)
        {
             cout<<"0"<<endl;//n=0,就是0个公司,怎样都没钱 
        }

        else
        {
             x=c/2/n;//n!=0

             if(-n*x*x+c*x>=-n*(x+1)*(x+1)+c*(x+1))
             cout<<x<<endl;//如果x较大,怕越界,上式应该简化
             else
             cout<<x+1<<endl; 
        }

    }
    return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值