Internet Service Providers

Description

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the N ISPs can get from using the channel. Notice that N, C, T, and the optimal T are integer numbers.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output

For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input

6

1 0

0 1

4 3

2 8

3 27

25 1000000000

Sample Output

Case 1: 0

Case 2: 0

Case 3: 0

Case 4: 2

Case 5: 4

Case 6: 20000000

题意:求获得一元二次方程的最大值的跟,

思路:当x=-b/(2*a)时,值最大,但不要忘记,这个数最大值的解可能为小数,但是用除法求的是整数,答案也是求的整数,所以在求一个x+1的值与其进行比较,取最大;

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define size 1000000
using namespace std;
int main()
{
	int n,c,l=1,t;
	scanf("%d",&t);
	
	while(t--)
	{
	    long long ans=0,k,h;
	    scanf("%d%d",&n,&c);
		printf("Case %d: ",l++);
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		k=c/(2*n);
		h=k+1;
		ans=k*(c-k*n)>=h*(c-h*n)?k:h;
		printf("%lld\n",ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值