B - FatMouse' Trade

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J i i pounds of JavaBeans and requires F i i pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J i i* a% pounds of JavaBeans if he pays F i i* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J i i and F i i respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
 
 
 
 
这道题基本的意思是:
先输入两个数,第一个代表猫粮的数量,第二个代表房间对的数量,接下来输入各个房间豆子的数量以及对应需要的猫粮数,根据豆子数与猫粮数的比值大小计算总共能换取多少豆子。
 
 
c++:
#include<iostream>
#include<algorithm>
#include<iomanip>
using namespace std;
struct tt
{
	double a;            //candy
	int b;               //number
	double c;            //chance
}z[1010];


bool compare(tt a,tt b)
{
	return a.c>b.c;
}


int main()
{
	//ios::sync_with_stdio("pause");
	int m,n;
	while(cin >> m >> n)
	{
		double s1=0;
		if(m==-1&&n==-1)
		{
			break;
		}
	//	tt *z=new tt[n];
		
		for(int i=0;i<n;++i)
		{
			cin >> z[i].a >> z[i].b;
			z[i].c=z[i].a/z[i].b;
			//cout << z[i].c << endl;;
		}
		sort(z,z+n,compare);
		for(int i=0;i<n;++i)
		{
			if(m>z[i].b)
			{
				m-=z[i].b;
				s1+=z[i].a;
			}
			else
			{
				s1+=z[i].c*m;
				break;
			}
		//	cout << "df" << s << endl;
		}
		cout.setf(ios::fixed);
		cout << setprecision(3) << s1 << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值