问题 E: FatMouse's Trade

389 篇文章 1 订阅
144 篇文章 2 订阅

问题 E: FatMouse’s Trade
时间限制: 1 Sec 内存限制: 32 MB
献花: 59 解决: 33
[献花][花圈][TK题库]
题目描述
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

输入
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

输出
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入
4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1
样例输出
2.286
2.500

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;

typedef struct
{
    int J;
    int F;
    double rate;
}CatJ;

bool cmp(CatJ a, CatJ b)
{
    return a.rate > b.rate;
}

int main()
{
#ifdef _DEBUG
    //freopen("data.txt", "r+", stdin);
    fstream cin("data.txt");
#endif // _DEBUG
    const int MaxN = 1010;
    int M, N;
    CatJ catj[MaxN];
    double remain;
    while (cin >> M >> N, !(M == -1 && M == -1))
    {
        for (int i = 0; i < N; ++i)
        {
            cin >> catj[i].J >> catj[i].F;
            catj[i].rate = (double)catj[i].J / catj[i].F;
        }

        sort(catj, catj + N, cmp);

        remain = 0;
        for (int i = 0; M > 0 && i < N; ++i)
        {
            if (catj[i].F <= M)
            {
                M -= catj[i].F;
                remain += catj[i].J;
            }
            else
            {
                remain += (double)M/catj[i].F * catj[i].J;
                M = 0;
            }
        }

        printf("%.3f\n", remain);
    }

#ifdef _DEBUG
    cin.close();
#ifndef _CODEBLOCKS
    system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}

/**************************************************************
    Problem: 2134
    User: Sharwen
    Language: C++
    Result: 升仙
    Time:3 ms
    Memory:1708 kb
****************************************************************/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值