ACM-oj -G - Aggressive cows

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3
Hint
OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题意:x轴上有N个点,你要选出C个点来,使得他们之间最近的距离最远。

方法:二分法

代码:

  #include<iostream>
  #include<algorithm>
  #include<cmath>
  //#define ll long long
  using namespace std;
  
  int a[100005];
  int n,c;
  
  bool f(int mid)
  {
  	int s = 0,l = 1;
  	for(int i = 1;i < n; ++i)
	{
	  	if((s + a[i] -a[i-1]) < mid)
	  	{
	  		s += a[i]-a[i-1];
		}
		else
		{
			s = 0;
			++l;
		}
	} 
	if(l < c)
	{
		return false;
	}
	else
	{
		return true;
	}
  }
 
  int main()
  {
  	cin >> n >> c;
  	for(int i=0;i<n;++i)
  	{
  		cin >> a[i];
	}
	sort(a,a+n);
	int low = a[n-1] - a[0];
	int high = a[n-1] - a[0];                      //找出最大距离
	for(int i = 1;i < n; ++i)
	{
		low = min(low,a[i]-a[i-1]);                //找出最小距离
	}
	while(low <= high)                             //将所有距离使用二分法,找出最优解
	{
		int mid = (low+high)/2;                    //假设mid是最优距离           
		if(f(mid))                                 //数组中距离大于mid的个数大于c,说明mid值偏小
		{
			low = mid + 1;                        
		}
		else                                       //mid值偏大
		{
			high = mid - 1;                       
		}
	}
	cout << high << endl;
  	return 0;
  }
    
    
要点:
要先把坐标排序,然后用在最短距离跟最大距离之间进行查找,每次二分判断最小距离为mid的个数.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值