hdoj 1432 Lining Up

Lining Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1923 Accepted Submission(s): 572

Problem Description
``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input
The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. No pair will occur twice in one test case.

Output
For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.

Sample Input
5
1 1
2 2
3 3
9 10
10 11

Sample Output
3

瞎胡翻译:第一行输入一个正整数n,之后n行给出n个点的横纵坐标,输出在一条直线上的点,最多有多少个。
蜜汁思路:先计算每个点和之后所有点的连线的斜率,然后把这些斜率存到数组k中,从k中找出有相同值的个数的最大值,加1之后就是结果

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int x[705],y[705];
        int i;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&x[i],&y[i]);
        }
        int ans=0;
        for(i=0;i<n;i++)
        {
            int j;
            int h=0;
            double k[705];
            for(j=i+1;j<n;j++)
            {
                k[h++]=1.0*(y[j]-y[i])/(x[j]-x[i]);
            }
            sort(k,k+h);
            int count=1;
            int m=2;
            for(j=0;j<h;j++)
            {
                if(k[j]==k[j-1])
                {
                    count++;    
                }
                else
                {
                    if(count+1>m)
                        m=count+1;
                    count=1;
                }
            }
            if(count+1>m)
                m=count+1;
            if(ans<m)
                ans=m;
        }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值