POJ 1988 Cube Stacking并查集

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 22236 Accepted: 7803
Case Time Limit: 1000MS
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P

  • Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
Source
USACO 2004 U S Open

题意:初始时有n个堆栈,每个堆栈上面1个cube。(编号都为1 ~ n),现在定义下面两个操作:
操作’M’ X Y: 按数据结构的栈来操作,将含有X元素的栈的元素,放到元素Y的上面
操作’C’ X:统计第X个cube下面含有多少个cube
思路:分别用under[i]保存第i个cube下面的cube数目;num[x]表示根为x的集合元素数;fat[x]表示元素x所在集合的根。
这里写图片描述这里写图片描述
例如:M X Y的操作变化如下
这里写图片描述

#include <stdio.h>
#include <fstream>
#include <string.h>
#include<iostream> 
#include<algorithm> 
using namespace std; 
const int maxn = 30005;   
int fat[maxn],P,x,y,num[maxn],under[maxn];
char m[10];  
int find(int x){
    int tmp=fat[x];
    if(x!=fat[x])
fat[x]=find(fat[x]),under[x]+=under[tmp];//为什么这里要加上under[tmp],见图一
    return fat[x];
}
void Union(int x,int y){
    int fx=find(x),fy=find(y);
    if(fx==fy) return;
    fat[fx]=fy;
    under[fx]+=num[fy];
    num[fy]+=num[fx];
}
int main(){  
freopen("i.txt","r",stdin);
     cin>>P;
     for(int i=0;i<maxn;i++) fat[i]=i,under[i]=0,num[i]=1;
     while(P--){
        scanf("%s",m);
        if(m[0]=='M'){
            scanf("%d%d",&x,&y);
            Union(x,y);
         }
         else{
            scanf("%d",&x);
            find(x);
            cout<<under[x]<<endl;
         }
     }
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值