BestCoder Round 38-1002 Greatest Greatest Common Divisor

题目链接:http://bestcoder.hdu.edu.cn/contests/contest_showproblem.php?cid=577&pid=1002


题面:


Greatest Greatest Common Divisor

 
 Accepts: 271
 
 Submissions: 1138
 Time Limit: 4000/2000 MS (Java/Others)
 
 Memory Limit: 65536/65536 K (Java/Others)
Problem Description

Pick two numbers  ai,aj(ij)  from a sequence to maximize the value of their greatest common divisor.

Input

Multiple test cases. In the first line there is an integer  T , indicating the number of test cases. For each test cases, the first line contains an integer  n , the size of the sequence. Next line contains  n  numbers, from  a1  to  an 1T100,2n105,1ai105 . The case for  n104  is no more than  10 .

Output

For each test case, output one line. The output format is Case # x ans x  is the case number, starting from  1 ans  is the maximum value of greatest common divisor.

Sample Input
2
4
1 2 3 4
3
3 6 9
Sample Output
Case #1: 2
Case #2: 3
题意:

    求给定序列中,任意两个数的公约数的最大值。

   hack的时候看了别人的代码,思路好像都差不多,看来是大众解法。

   一个数的因子可以只枚举到他的平方根,另一边除一下即可。然后,用一个数组来保存每个因子个数。最后从大往小枚举,当碰到某个因子大于等于2时,即为答案。


代码:

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
using namespace std;
int store[100010],status[100010];
int main()
{
    int n,t,maxx,tmp;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        memset(status,0,sizeof(status));
        scanf("%d",&n);
        for(int j=0;j<n;j++)
        {
           scanf("%d",&store[j]);
        }
            for(int k=0;k<n;k++)
            {
                tmp=store[k];
                for(int x=1;x*x<=tmp;x++)
                {
                    if(tmp%x==0)
                    {
                     status[x]++;
                     status[tmp/x]++;
                    }
                }
            } 
        for(int x=100000;x>=1;x--)
        {
            if(status[x]>=2)
            {
                maxx=x;
                break;
            }
        }
        printf("Case #%d: %d\n",i,maxx);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值