POJ 2151 Check the difficulty of problems

题目链接:POJ 2151 Check the difficulty of problems


题面:

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5519 Accepted: 2431

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石


第一次写概率DP,感觉和DP有些不一样,借鉴了这篇博客:金海峰


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
double correspond[1005][31];
double dp[1005][31][31];
int main()
{
	int n,m,t;
	double ans=1,tmp,sum;
	while(scanf("%d%d%d",&m,&t,&n)&&(m||t||n))
	{
		ans=tmp=1;
		for(int i=0;i<t;i++)
		{
			for(int j=1;j<=m;j++)
			  scanf("%lf",&correspond[i][j]); 
		}
		memset(dp,0,sizeof(dp)); 
		//dp[i][j][k] 第i只队伍,做前j题,做对k题的概率 
		for(int i=0;i<t;i++)
	     {
          dp[i][0][0]=1;
          for (int j=1;j<=m;j++)
          {
       	     //还是做对0道,那么就是当前这一道没做对 
             dp[i][j][0] = dp[i][j -1][0] * (1- correspond[i][j]);
             for (int k =1; k <= j; k++)
               //做对k道,要么是之前就做对了k道,这次没对,要么就是之前对了k-1道,这次对了 
               dp[i][j][k] = dp[i][j -1][k -1] * correspond[i][j]+ dp[i][j -1][k] * (1- correspond[i][j]);
          }
		 }
	    //排除任何一个人一道都没做对的情况 
        for(int i=0;i<t;i++)
          ans *=(1- dp[i][m][0]);
        //排除所有人都只做对1~n-1的情况 
       for(int i=0;i<t;i++)
        {
          sum=0;
          for(int j=1;j<n;j++)
          sum+=dp[i][m][j];
          tmp*=sum;
        }
       ans-=tmp;
       printf("%.3f\n", ans);
	}
	return 0;
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值