HDU 1297 Children’s Queue

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1297


题面:

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13363    Accepted Submission(s): 4379


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 

Author
SmallBeer (CML)
 

题目大意:
    给定队伍长度,求不出现单独一个女生的方案数。

解题:
    可以用dp三维来解决这个问题。dp[i][j][k],i表示是第i位,j为1表示男生,j为0表示女生,k为0表示0个女生,k为1表示1个女生,k为2表示多个女生,即合法状态。
    递推关系如下:
     
dp[i+1][0][2]=dp[i+1][0][2].add(dp[i][0][1]);
dp[i+1][0][2]=dp[i+1][0][2].add(dp[i][0][2]);
dp[i+1][1][0]=dp[i+1][1][0].add(dp[i][0][2]);
dp[i+1][1][0]=dp[i+1][1][0].add(dp[i][1][0]);
dp[i+1][0][1]=dp[i+1][0][1].add(dp[i][1][0]);

部分状态虽然不符合最后的要求,即女生不可落单,但计算过程中需要用到相应值,最后的答案为,dp[n][1][0]+dp[n][0][2]
代码:
import java.io.*;
import java.util.*;
import java.math.*;
public class Main{
	public static void main(String args[])
	{
		BigInteger dp[][][]=new BigInteger [1005][2][3];
		Scanner sc =new Scanner(new BufferedInputStream(System.in));
		PrintWriter cout=new PrintWriter(System.out);
		for(int i=0;i<=1004;i++)
			for(int j=0;j<=1;j++)
				for(int k=0;k<=2;k++)
					dp[i][j][k]=BigInteger.ZERO;
		dp[1][0][1]=BigInteger.valueOf(1);
		dp[1][1][0]=BigInteger.valueOf(1);
		for(int i=1;i<=1000;i++)
		{
			dp[i+1][0][2]=dp[i+1][0][2].add(dp[i][0][1]);
			dp[i+1][0][2]=dp[i+1][0][2].add(dp[i][0][2]);
			dp[i+1][1][0]=dp[i+1][1][0].add(dp[i][0][2]);
			dp[i+1][1][0]=dp[i+1][1][0].add(dp[i][1][0]);
			dp[i+1][0][1]=dp[i+1][0][1].add(dp[i][1][0]);
		}
		int t;
		while(sc.hasNext())
		{
           t=sc.nextInt();
		   cout.println(dp[t][0][2].add(dp[t][1][0]));
		}
		cout.flush();
	}
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值