1050 String Subtraction (20分)

Given two strings S​​1 and S​2, S=S​1−S​2 ​​is defined to be the remaining string after taking all the characters in S​2 from S1. Your task is simply to calculate S​1​​−S​2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1 and S2, respectively. The string lengths of both strings are no more than 10​4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1−S​2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题⽬⼤意:

给出两个字符串,在第⼀个字符串中删除第⼆个字符串中出现过的所有字符并输出

分析:

⽤cha[256]数组变量标记str1出现过的字符为true,str2出现过的字符为false,输出str1的时候根据cha[str1[i]]是否为true,如果是true就输出

//1050 String Subtraction (20分) 
#include <iostream>
#include <string>
using namespace std; 
bool cha[256];

int main() 
{
	string s1,s2;
	getline(cin,s1);
	getline(cin,s2);
	for(int i=0;i<s1.size();i++)
	{
		cha[s1[i]]=true;
	}
	for(int i=0;i<s2.size();i++)
	{
		cha[s2[i]]=false;
	}
	for(int i=0;i<s1.size();i++)
	{
		if(cha[s1[i]])
			cout<<s1[i];
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值