1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题⽬⼤意:

现已知n个考⽣的3⻔分数,平均分可以按照这三⻔算出来。然后分别对这四个分数从⾼到低排序,这样对每个考⽣来说有4个排名。k个查询,对于每⼀个学⽣id,输出当前id学⽣的最好的排名和它对应的分数,如果名次相同,按照A>C>M>E的顺序输出,如果当前id不存在,输出N/A

分析:

1、⽤结构体存储学⽣的id、四⻔成绩、四⻔排名、对应关系为,0-E 1-M 2-C 3-A
2、排名并列应该1、1、3、4、5,⽽不是1、1、2、3、4,否则会有⼀个测试点不过
3、平均分是四舍五⼊的,所以需要按照+0.5后取整,保证是四舍五⼊的(听说不四舍五⼊也能通
过…)
4、在取最优排名后一个学科跟前一学科排名相等时,也要更新最优排名,因为后一学科优先级更高
5、存储的时候就按照E M C A的顺序存储可以简化程序逻辑
6、⽤exist数组保存当前id是否存在,这个id对应的stu结构体的下标是多少。⽤i+1可以保证为0的都是
不存在的可以直接输出N/A,其余不为0的保存的值是对应的结构体index + 1的值

//1012 The Best Rank (25分)
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
struct stu
{
	int id,best;
	int score[4];//0-E 1-M 2-C 3-A
	int rank[4];//0-E 1-M 2-C 3-A
};
stu s[2005];
int flag=0,exist[1000000];
bool cmp(stu s1,stu s2)
{
	return s1.score[flag]>s2.score[flag];
}
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=0; i<n; i++)
	{
		scanf("%d %d %d %d",&s[i].id,&s[i].score[2],&s[i].score[1],&s[i].score[0]);//C M E
		s[i].score[3]=(s[i].score[0]+s[i].score[1]+s[i].score[2])/3+0.5;//四舍五入 
	}
	for(flag=0; flag<4; flag++)
	{
		sort(s,s+n,cmp);
		s[0].rank[flag]=1;
		for(int j=1; j<n; j++)
		{
			s[j].rank[flag]=j+1;
			if(s[j].score[flag]==s[j-1].score[flag])//分数相等排名也相等,即并列 
				s[j].rank[flag]=s[j-1].rank[flag];
		}
	}
	for(int j=0; j<n; j++)
	{
		exist[s[j].id]=j+1;
		int best=0;
		for(int k=1; k<4; k++)
			if(s[j].rank[k]<=s[j].rank[best])
				best=k;//排名更高或者排名相等但时优先级更高
		s[j].best=best;
	}
	char str[4]= {'E','M','C','A'};
	for(int i=0; i<m; i++)
	{
		int id;
		scanf("%d",&id);
		int temp=exist[id];
		if(temp)
			printf("%d %c\n",s[temp-1].rank[s[temp-1].best],str[s[temp-1].best]);
		else
			printf("N/A\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值