1012 The Best Rank (25 分)

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

Analysis

这是一道排序的入门简单题,坑点不多,唯一会卡的点就是在分数一样时排名也要相同。

我的思路很简单,把数据读取以后对每科都进行一次排序,并记录该课排名然后输出。所以代码里有一些冗杂的地方可以用 数组+循环 改进。

Code(C++)

#include <iostream>
#include <algorithm>
using namespace std;

struct student {
    string id;
    int c_pro;
    int math;
    int english;
    int ave;
    int rank_c, rank_m, rank_e, rank_a;
};
typedef struct student Stu;

bool cmp_c(Stu a, Stu b)
{
    return a.c_pro > b.c_pro;
}
bool cmp_m(Stu a, Stu b)
{
    return a.math > b.math;
}
bool cmp_e(Stu a, Stu b)
{
    return a.english > b.english;
}
bool cmp_a(Stu a, Stu b)
{
    return a.ave > b.ave;
}

int Minn(int a, int b, int c, int d)
{
    return min(min(a, b), min(c, d));
}

int main()
{
    int numStu, numTest;
    cin >> numStu >> numTest;
    
    Stu stu[numStu];
    for(int i=0; i<numStu; i++)
    {
        cin >> stu[i].id >> stu[i].c_pro >> stu[i].math >> stu[i].english;
        stu[i].ave = (stu[i].c_pro + stu[i].math + stu[i].english) / 3;
    }
    
    sort(stu, stu+numStu, cmp_c);
    for(int i=0; i<numStu; i++)
    {
        if(i!=0 && stu[i].c_pro == stu[i-1].c_pro)
            stu[i].rank_c = stu[i-1].rank_c;
        else
            stu[i].rank_c = i + 1;
    }
    sort(stu, stu+numStu, cmp_m);
    for(int i=0; i<numStu; i++)
    {
        if(i!=0 && stu[i].math == stu[i-1].math)
            stu[i].rank_m = stu[i-1].rank_m;
        else
            stu[i].rank_m = i + 1;
    }
    sort(stu, stu+numStu, cmp_e);
    for(int i=0; i<numStu; i++)
    {
        if(i!=0 && stu[i].english == stu[i-1].english)
            stu[i].rank_e = stu[i-1].rank_e;
        else
            stu[i].rank_e = i + 1;
    }
    sort(stu, stu+numStu, cmp_a);
    for(int i=0; i<numStu; i++)
    {
        if(i!=0 && stu[i].ave == stu[i-1].ave)
            stu[i].rank_a = stu[i-1].rank_a;
        else
            stu[i].rank_a = i + 1;
    }
    
    for(int i=0; i<numTest; i++)
    {
        string query;
        cin >> query;
        
        bool flag = false;
        int j;
        for(j=0; j<numStu; j++)
            if(stu[j].id == query)
            {
                flag = true;
                break;
            }
        
        if(flag)
        {
            int tmp = Minn(stu[j].rank_a,stu[j].rank_c,stu[j].rank_m,stu[j].rank_e);
            if(stu[j].rank_a == tmp)
                cout << stu[j].rank_a << " A" << endl;
            else if(stu[j].rank_c == tmp)
                cout << stu[j].rank_c << " C" << endl;
            else if(stu[j].rank_m == tmp)
                cout << stu[j].rank_m << " M" << endl;
            else
                cout << stu[j].rank_e << " E" << endl;
        }
        else
            cout << "N/A" << endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值