1117 Eddington Number (25分)

13 篇文章 0 订阅

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题⽬⼤意:

英国天⽂学家爱丁顿很喜欢骑⻋。据说他为了炫耀⾃⼰的骑⻋功⼒,还定义了⼀个“爱丁顿
数”E,即满⾜有E天骑⻋超过E英⾥的最⼤整数E。据说爱丁顿⾃⼰的E等于87。

分析:

在数组a中存储n天的公⾥数,对n个数据从⼤到⼩排序,i表示了骑⻋的天数,那么满⾜a[i] > i+1
的最⼤i+1即为所求

//1117 Eddington Number (25分)
#include <iostream>
#include <algorithm>
using namespace std;
int a[1000000];
int main()
{
	int n, e = 0;
	scanf("%d", &n);
	for(int i = 0; i < n; i++)
		scanf("%d", &a[i]);
	sort(a, a+n, greater<int>());
	while(e < n && a[e] > e+1) 
		e++;
	printf("%d", e);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值