1015 Reversible Primes (20分)

4 篇文章 0 订阅
3 篇文章 0 订阅

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意

如果⼀个数本身是素数,⽽且在d进制下反转后的数在⼗进制下也是素数,就输出Yes,否则就输出No

分析

判断输⼊是否为负数,判断n是否为素数,把n转换为d进制再反过来转换为10进制,判断是否为素数

//1015 Reversible Primes (20分)
#include<iostream>
#include<stack>
#include<cmath>
using namespace std;
bool isPrime(int x)
{
	if(x<=1)
		return false;
	for(int i=2; i*i<=x; i++)
	{
		if(x%i==0)
			return false;
	}
	return true;
}
int main()
{
	int n,d;
	stack<int> s;
	while(scanf("%d",&n)&&n>=0)
	{
		bool flag1=false,flag2=false;
		scanf("%d",&d);
		flag1=isPrime(n);
		int j=0,temp=0;
		if(!flag1)
		{
			cout<<"No"<<endl;
			continue;
		}
		while(n!=0)
		{
			s.push(n%d);
			n=n/d;
		}
		while(s.size())
		{
			temp=temp+s.top()*pow(d,j);//倒置后转为10进制 
			s.pop();
			j++;
		}
		//cout<<temp;
		flag2=isPrime(temp);
		if(flag1&&flag2)
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值