1058 A+B in Hogwarts (20分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

题⽬⼤意:

17个Sickle对换⼀个Galleon,29个Knut对换⼀个Sickle。根据Galleon.Sickle.Knut的⽅式相加A和B,实际就是加分的进位

//1058 A+B in Hogwarts (20分)
#include <iostream>
using namespace std;
int main()
{
	int a[3],b[3],c[3],add=0;
	scanf("%d.%d.%d %d.%d.%d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2]);
	c[2]=a[2]+b[2];
	add=c[2]/29;
	c[2]=c[2]%29;

	c[1]=a[1]+b[1]+add;
	add=c[1]/17;
	c[1]=c[1]%17;

	c[0]=a[0]+b[0]+add;
	printf("%d.%d.%d",c[0],c[1],c[2]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值