1094 The Largest Generation (25分)

1 篇文章 0 订阅

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

题⽬⼤意:

输⼊树的结点个数N,结点编号为1~N,⾮叶⼦结点个数M,然后输出M个⾮叶⼦结点格⼦的孩⼦结点的编号,求结点个数最多的⼀层,根结点的层号为1,输出该层的结点个数以及层号

分析:

⽤DFS或者BFS,⽤DFS就⽤参数index和level标记当前遍历的结点的编号和层数,⼀个数组book标记当前层数level所含结点数,最后遍历⼀遍数组找出最⼤值。
注意 :book[level]++;这句话是发⽣在return语句判断之前的外⾯,即每遇到⼀个结点都要进⾏处理,⽽不是放在return语句的条件判断⾥⾯

//1094 The Largest Generation (25分) 
#include <iostream>
#include <vector>
using namespace std;
vector<int> v[105];
int book[105];
void dfs(int index,int level)
{
	book[level]++;
	for(int i=0;i<v[index].size();i++)
	{
		dfs(v[index][i],level+1);
	}
}
int main()
{
	int n,m;
	cin>>n>>m;
	for(int i=0;i<m;i++)
	{
		int a,cnt;
		cin>>a>>cnt;
		for(int j=0;j<cnt;j++)
		{
			int child;
			cin>>child;
			v[a].push_back(child);
		}
	}
	dfs(1,1);
	int max=book[0];
	for(int i=1;i<105;i++)
	{
		if(book[i]>max)
			max=i;
	}
	cout<<book[max]<<" "<<max<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值