PAT甲级 - 1021 Deepest Root (25分)

40 篇文章 0 订阅
35 篇文章 0 订阅

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

自己写出来的一道题目,因为题目中限制了边的个数为n-1,不可能形成一个大环,思路还是找连通块个数,连通块个数>1,说明存在环,直接输出连通块个数即可;连通块个数 == 1,说明是tree,从每个顶点出发,记录max_depth即可。

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 10010;
vector<int> Adj[maxn];
vector<int> ans;
int n;
int visited[maxn] = { false };

void DFS(int v) {
	visited[v] = true;
	for (int i = 0; i < Adj[v].size(); i++) {
		if (visited[Adj[v][i]] == false)
			DFS(Adj[v][i]);
	}
}
int max_depth;
int cur_depth = 0;
void init() {
	cur_depth = 0;
	for (int i = 1; i <= n; i++) {
		visited[i] = false;
	}
}


void Find_deepest(int v, int depth) {
	visited[v] = true;
	if (depth > cur_depth)
	{
		cur_depth = depth;
	}
	for (int i = 0; i < Adj[v].size(); i++) {
		if (visited[Adj[v][i]] == false)
			Find_deepest(Adj[v][i], depth + 1);
	}
}
int main() {
	scanf("%d", &n);
	int v1, v2;
	for (int i = 0; i < n - 1; i++) {
		scanf("%d%d", &v1, &v2);
		Adj[v1].push_back(v2);
		Adj[v2].push_back(v1);
	}
	int block = 0;
	for (int i = 1; i <= n; i++) {
		if (visited[i] == false) {
			DFS(i);
			block++;
		}
	}
	if (block > 1) {
		printf("Error: %d components", block);
	}
	else {
		for (int i = 1; i <= n; i++)
		{
			init();
			Find_deepest(i, 0);
			if (cur_depth > max_depth) {
				max_depth = cur_depth;
				ans.clear();
				ans.push_back(i);
			}
			else if (cur_depth == max_depth) {
				ans.push_back(i);
			}
		}
		sort(ans.begin(), ans.end());
		for (int i = 0; i < ans.size(); i++) {
			printf("%d\n", ans[i]);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值