PAT甲级 -1013 Battle Over Cities (25分) 求连通块的数量

40 篇文章 0 订阅
35 篇文章 0 订阅

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

题目详情

首先利用邻接表建立图,然后利用并查集,确定连通块的数量,最终答案为连通块的数目 - 1;

/*
n, m, k
cities, remaining highways, cities to be checked
*/
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;

int n, m, k;
const int maxn = 1010;
int father[maxn];
int visited[maxn] = { 0 };
vector<int> G[maxn];

int FindFather(int v) { // 根节点的father等于他自身
	int z = v;
	while (v != father[v]) {
		v = father[v];
	}
	int root = v;
	while (z != father[z]) { //路径压缩
		int tmp = z;
		z = father[z];
		father[tmp] = root;
		
	}
	return root;
}

void Union(int v1, int v2) {
	int faA = FindFather(v1);
	int faB = FindFather(v2);
	if (faA != faB) father[faA] = faB;
}

void init() {
	for (int i = 1; i <= n; i++) { // 从1开始计数时,注意等于号!
		father[i] = i;
		visited[i] = false;
	}
}

int main() {

	scanf("%d%d%d", &n, &m, &k);
	int v1, v2, v;
	for (int i = 0; i < m; i++) {
		scanf("%d%d", &v1, &v2);
		G[v1].push_back(v2);
		G[v2].push_back(v1);
	}

	for (int i = 1; i <= k; i++) {
		scanf("%d", &v); //v是需要删除的结点编号
		
		init();

		for (int j = 1; j <= n; j++) { //遍历所有的边
			for (int l = 0; l < G[j].size(); l++) {
				int a = j, b = G[j][l];
				if (a == v || b == v) continue;
				Union(a, b);
			}
		}

		int block = 0;
		for (int x = 1; x <= n; x++) {
			if (x == v) continue;
			int father = FindFather(x);
			if (visited[father] == false) {
				block++;
				visited[father] = true;
			}
		}
		printf("%d\n", block - 1);
	}


	return 0;
}

 同样是求连通块,使用DFS也可以实现,不过要注意避开currentPoint

同时注意==和= 

/*
n, m, k
cities, remaining highways, cities to be checked
*/
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;

int n, m, k;
const int maxn = 1010;
vector<int> G[maxn]; //G[i]存放的是i边的邻接边,j是索引,G[i][j]是另一条边
int visited[maxn] = { false };

void init() {
	for (int i = 1; i <= n; i++) {
		visited[i] = false;
	}
}
int currentPoint;
void DFS(int i) {
	visited[i] = true;	
	for (int j = 0; j < G[i].size(); j++) {
		if(G[i][j] != currentPoint && visited[G[i][j]] == false)
			DFS(G[i][j]);
	}
}

int main() {

	scanf("%d%d%d", &n, &m, &k);
	int v1, v2, v;
	for (int i = 0; i < m; i++) {
		scanf("%d%d", &v1, &v2);
		G[v1].push_back(v2);
		G[v2].push_back(v1);
	}
	int query;
	for (int query = 1; query <= k; query++) {
		scanf("%d", &currentPoint); //v是需要删除的结点编号
		init();
		int block = 0;
		for (int i = 1; i <= n; i++) {
			if (i != currentPoint && visited[i] == false) {
				DFS(i);
				block++;
			}
		}
		printf("%d\n", block - 1);
	}


	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值