GDUT_寒假训练题解报告_数论专题_个人题解报告——题目:E - Revenge of GCD【HDU - 5019】【数论(GCD,因数分解)】

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=5019
题目:

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
—Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]

  1. 1 <= T <= 100
  2. 1 <= X, Y, K <= 1 000 000 000 000

Output

For each test case, output the k-th GCD of X and Y. If no such integer exists,
output -1.

Sample Input

3
2 3 1
2 3 2
8 16 3

Sample Output

1
-1
2

这个玩意,我因为long long又死了一遍,其实不难,就是最大公因数的第k个因数就行了。

虽然是这么说,但是没有卡极限数据感觉,如果极限数据,我找所有因数的时候,用的是暴力,time*time<=GCD(a,b),也就是次数time最大可以达到1e6,然后t范围是1e2,最大是1e8已经要爆表了

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <climits>
#include <queue>
#include <stack>
#include <map>
//鬼畜头文件
using namespace std;
#define INF 0x3f3f3f3f
#define LLU unsigned long long
#define LL long long
const int mod =1e9+7;
//鬼畜define
int t;
LL a,b,k;

LL gcd(LL a,LL b)
{
	if(b==0)return a;
	return gcd(b,a%b);
}
bool cmp(LL a,LL b)
{
	return a>b;
}
LL all[10000];
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		int ans=1;
		scanf("%lld %lld %lld",&a,&b,&k);
		LL point=gcd(a,b);
		int num=0;
		LL time;
		for(time=1;time*time<point;time++)
		{
			if(point%time==0)
			{
				all[num++]=time;
				all[num++]=point/time;
			}
		}
		if(time*time==point)all[num++]=time;

		if(num>=k){sort(all,all+num,cmp);printf("%lld\n",all[k-1]);}
		else printf("-1\n");
	}


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值