HDU 5019 - Revenge of GCD(GCD+因数分解)

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3903    Accepted Submission(s): 1098


 

Problem Description

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.

 

 

Input

The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000

 

 

Output

For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.

 

 

Sample Input

 

3

2 3 1

2 3 2

8 16 3

 

 

Sample Output

 

1

-1

2

 

题意:求x和y 的第k大的最大公约数

思路:第k大的公约数必定是gcd(x,y)的因数,我们先求出gcd(x,y)然后求出因数,排序后判断输出。

#include<bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define ll long long

const int maxn = 1e5+10;

ll t,x,y,k,num,n;
ll a[maxn];
ll gcd(ll a,ll b){
    return b==0 ? a : gcd(b,a % b);
}
void prime_num(ll n){
    num = 0;
    for(ll i=1;i*i<=n;i++){
        if(n % i == 0){
            a[num++] = i;
            if(i * i != n)
                a[num++] = n / i;
        }
    }
}
bool cmp(ll a,ll b){
    return a > b;
}
int main(){
    scanf("%lld",&t);
    while(t--){
        clr(a);
        scanf("%lld%lld%lld",&x,&y,&k);
        n = gcd(x,y);
        prime_num(n);
        if(k > num) printf("-1\n");
        else{
            sort(a,a+num,cmp);
            printf("%lld\n",a[k-1]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值