题目链接:http://poj.org/problem?id=2478
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10
6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
思路:由a / b,gcd(a,b)=1知,当前f(n)是在f(n - 1)的基础上加上以n为分母,与n互质的数为分子的分数,所以f(n)比f(n - 1)增加了1~n内与n互质的数的个数,现在题意就很明显了,就是要求欧拉函数,不过需要一个前缀和。
代码实现如下:
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define debug(x) cout <<'[' <<x <<']' <<endl;
const int maxn = 1e6 + 7;
int n, m;
int v[maxn], p[maxn], phi[maxn];
long long sum[maxn];
void euler() {
m = 0;
memset(v, 0, sizeof(v));
memset(sum, 0, sizeof(sum));
for(int i = 2; i < maxn; i++) {
if(v[i] == 0) {
v[i] = i;
p[m++] = i;
phi[i] = i - 1;
}
for(int j = 0; j < m; j++) {
if(p[j] > v[i] || p[j] > maxn / i) break;
v[i * p[j]] = p[j];
phi[i * p[j]] = phi[i] * (i % p[j] ? p[j] - 1 : p[j]);
}
}
phi[0] = phi[1] = 0;
for(int i = 1; i < maxn; i++) {
sum[i] = sum[i - 1] + phi[i];
}
}
int main() {
euler();
while(~scanf("%d", &n) && n) {
// debug(phi[n]);
printf("%lld\n", sum[n]);
}
}