The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:5 1 2 4 14 9 3 1 3 2 5 4 1Sample Output:
3 10 7
我的AC代码如下;
#include <cstdio>
const int maxn = 100005;
int dis[maxn], sum, n;
int main() {
scanf("%d", &n);
int num;
dis[0] = 0;
sum = 0;
for (int i = 1; i <= n; i++) {
scanf("%d", &num);
dis[i] = dis[i-1]+num;
sum += num;
}
int m, left, right;
int ans, n_ans;
scanf("%d", &m);
while (m--) {
scanf("%d%d", &left, &right);
if (left > right) {
int tmp = left;
left = right;
right = tmp;
}
ans = dis[right - 1] - dis[left - 1];
n_ans = sum - ans;
if (ans > n_ans) {
ans = n_ans;
}
printf("%d\n", ans);
}
return 0;
}
注:一段一段保存总和,例如dis[1]是从第0个点到第1个点的距离,而dis[2]是从第0个点开始到第2个点的距离。
所以第1个点到第2个点的距离是dis[2]-dis[1];
但是由于输入时是从1开始计入的,所以是dis[left-1]-dis[right-1]