一只小蜜蜂...
Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
Sample Input
2 1 2 3 6
Sample Output
1 3
分析:
我们可以分析一下
图一 图二
由以上两图可知:每个蜂房最多只能由两个地方到达
当 1 --> 2时:会有 1 条路线 (1-->2)
当 1 --> 3时:会有 2 条路线(1-->2-->3;1-->3)
当 1 --> 4时:会有 3条路线 (1-->2-->4;1-->3-->4;;1-->2-->3-->4;)
当 1 --> 5时:会有 5条路线 (1-->3-->5;1-->2->3-->5;1-->2-->4-->5;1-->3-->4-->5;;1-->2-->3-->4-->5)
......
当 3 --> 4 时:会有 1 条路线(3-->4)
当 3 --> 5时:会有 2 条路线(3-->5;3-->4-->5)
当 3 --> 6时:会有 3 条路线(3-->4-->6;3-->4-->6;3-->4-->5-->6)
....
我们会发现当首尾
相差 1 时:就会有 1 条路径
相差 2 时:就会有 2 条路径
相差 3 时:就会有 3 条路径
相差 4 时:就会有 5 条路径
相差 5 时:就会有 8 条路径
可总结出一条公式 : DP(n)=DP(n-1)+DP(n-3) (n>2)
参考代码:
package DP;
import java.util.Scanner;
public class LittleBee {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
int N=sc.nextInt();
int a,b,s;
int[] result=new int[50];
result[0]=1;
result[1]=1;
result[2]=2;
for (int i = 3; i < 50; i++) {
result[i]=result[i-1]+result[i-2];
}
for(int i=0;i<N;i++){
a=sc.nextInt();
b=sc.nextInt();
s=b-a;
System.out.println(result[s]);
}
sc.close();
}
}