POJ 2676 Sudoku 数独


Sudoku
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12360 Accepted: 6168 Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

Source



数独问题,给你一个9*9的方格,要求每行每列的9个数字都不相同,然后将这方格,分成9个3*3的小方格,要求每个小方格里面的数字也都不相同。现在给你一些数字,0代表你要添加的数字,使其形成一个数独。
枚举9个数字+dfs深搜,每一行都是一个数,不能一个数字一个数字写入,只能是一个字符一个字符写入。

#include<stdio.h>
#include<string.h>
using namespace std;
int vis[107][2],g[10][10];
int num;

bool judge(int x,int y,int k)
{
    for(int i=0;i<9;i++)
    {
        if(g[i][y]==k)return false;
        if(g[x][i]==k)return false;
    }
    int xx=(x/3)*3;
    int yy=(y/3)*3;
    for(int i=0;i<3;i++)
        for(int j=0;j<3;j++)
            if(g[i+xx][j+yy]==k)
                return false;
    return true;
}

int dfs(int idx)
{
    if(idx<0)return 1;
    for(int i=1;i<=9;i++)
    {
        int x=vis[idx][0];
        int y=vis[idx][1];
        if(judge(x,y,i))
        {
            g[x][y]=i;
            if(dfs(idx-1))return 1;
            g[x][y]=0;
        }
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        num=0;
        char c;
        for(int i=0;i<9;i++)
            for(int j=0;j<9;j++)
            {
                scanf(" %c",&c);
                g[i][j]=c-'0';
                if(g[i][j]==0)
                {
                    vis[num][0]=i;
                    vis[num++][1]=j;
                }
            }
        dfs(num-1);
        for(int i=0;i<9;i++)
        {
            for(int j=0;j<9;j++)
                printf("%d",g[i][j]);
            printf("\n");
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值