POJ 1426 Find The Multiple 寻找倍数


Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16110 Accepted: 6585 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source


给出一个正整数n,找出一个非零倍数,使得这个倍数的十进制形式只由0和1组成。
只对余数的尾数进行填0或1操作,等效于对原数操作。
//388K	94MS
#include<stdio.h>
#include<string.h>
char s[107];
int flag;
void dfs(int r,int digit,int n)
{
    if(digit>100)return;
    if(!r)//如果余数为0,则找到
    {
        flag=true;
        s[digit]=0;
        return;
    }
    if(!flag)//在末尾填0
    {
        s[digit]='0';
        dfs((r*10)%n,digit+1,n);
    }
    if(!flag)//在末尾填1
    {
        s[digit]='1';
        dfs((r*10+1)%n,digit+1,n);
    }
}
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        memset(s,0,sizeof(s));
        s[0]='1';
        flag=false;
        dfs(1,1,n);
        printf("%s\n",s);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值