POJ 1286 Necklace of Beads Polya定理


Necklace of Beads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6253 Accepted: 2606

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source


跟这个题是一样的,只不过固定是三种颜色而已。点击打开链接
//380K	0MS
#include<stdio.h>
#include<math.h>
long long gcd(long long a,long long b)
{
    if(!b)return a;
    return gcd(b,a%b);
}
int main()
{
    long long s;
    while(scanf("%I64d",&s)&&s!=-1)
    {
        if(s==0){printf("0\n");continue;}
        long long sum=0;
        for(long long i=1;i<=s;i++)
        {
            long long tmp=gcd(s,i);//第i次旋转的循环节数
            sum+=(long long)(pow(3.0,tmp*1.0));
        }
        if(s&1)sum+=(long long)(s*pow(3.0,(s+1)/2.0));//s为奇数,共有s个循环节数均为(s+1)/2的置换
        else//当s为偶数
        {
            sum+=(long long)((s/2)*pow(3.0,(s+2)/2.0));//第一种循环节数均为(s+2)/2
            sum+=(long long)((s/2)*pow(3.0,s/2.0));//第二种循环节数均为s/2
        }
        sum/=(2*s);
        printf("%I64d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的高校科研信息管理系统实现了操作日志管理、字典管理、反馈管理、公告管理、科研成果管理、科研项目管理、通知管理、学术活动管理、学院部门管理、科研人员管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让高校科研信息管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值