POJ 1286 Necklace of Beads Polya定理


Necklace of Beads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6253 Accepted: 2606

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source


跟这个题是一样的,只不过固定是三种颜色而已。点击打开链接
//380K	0MS
#include<stdio.h>
#include<math.h>
long long gcd(long long a,long long b)
{
    if(!b)return a;
    return gcd(b,a%b);
}
int main()
{
    long long s;
    while(scanf("%I64d",&s)&&s!=-1)
    {
        if(s==0){printf("0\n");continue;}
        long long sum=0;
        for(long long i=1;i<=s;i++)
        {
            long long tmp=gcd(s,i);//第i次旋转的循环节数
            sum+=(long long)(pow(3.0,tmp*1.0));
        }
        if(s&1)sum+=(long long)(s*pow(3.0,(s+1)/2.0));//s为奇数,共有s个循环节数均为(s+1)/2的置换
        else//当s为偶数
        {
            sum+=(long long)((s/2)*pow(3.0,(s+2)/2.0));//第一种循环节数均为(s+2)/2
            sum+=(long long)((s/2)*pow(3.0,s/2.0));//第二种循环节数均为s/2
        }
        sum/=(2*s);
        printf("%I64d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值