D - A Simple Math Problem HDU - 5974(数论)

Given two positive integers a and b,find suitable X and Y to meet the conditions:X+Y=a
Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*104),b(1≤b≤109),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).
Sample Input
6 8
798 10780
Sample Output
No Solution
308 490

如果存在x,y,则一定满足 gcd(x,y) == gcd(a,b),再根据题目,可以列出一元二次方程组,根据解求出x,y。

看了大佬题解才想出来的,大佬题解链接

#include <bits/stdc++.h>
using namespace std;
int f(int x) {
    int a = sqrt(x);
    if (a * a == x) return 1;
    return 0;
}
int main() {
    int a, b, c, d, x, y;
    while (cin >> a >> b) {
        c = __gcd(a, b);
        a /= c;
        b /= c;
        d = a * a - 4 * b;
        if (d >= 0 && f(d)) {
            x = (a - sqrt(d)) / 2 * c;
            y = (a + sqrt(d)) / 2 * c;
            printf("%d %d\n", x, y);
        } else
            puts("No Solution");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值