国庆弱校 Carries

B. Carries

Time Limit: 1000ms
Memory Limit: 65536KB
64-bit integer IO format:  %lld      Java class name:  Main
frog has  n  integers  a1,a2,,an , and she wants to add them pairwise.
 
Unfortunately, frog is somehow afraid of carries (进位). She defines \emph{hardness}  h(x,y)  for adding  x  and  y  the number of carries involved in the calculation. For example,  h(1,9)=1,h(1,99)=2 .
 
Find the total hardness adding  n  integers pairwise. In another word, find
1i<jnh(ai,aj)
.

Input

The input consists of multiple tests. For each test:
 
The first line contains  1  integer  n  ( 2n105 ). The second line contains  n  integers  a1,a2,,an . ( 0ai109 ).

Output

For each test, write  1  integer which denotes the total hardness.

Sample Input

2
5 5
10
0 1 2 3 4 5 6 7 8 9

Sample Output

1
20

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;
#define N 100000 + 10

int n, a[N], b[N], x[12];

int main()
{
    x[0] = 1;
    for(int i = 1; i <= 9; i++) x[i] = x[i - 1] * 10;
    while(~scanf("%d", &n))
    {
        for(int i = 0; i < n; i++)
        scanf("%d", &a[i]);

        long long ans = 0;
        for(int k = 0; k <= 9; k++)
        {
            for(int i = 0; i < n; i++)
            b[i] = a[i] % x[k];
            sort(b, b + n);
            for(int i = 0; i < n; i++)
            {
                int tmp = x[k] - b[i];
                int pos = lower_bound(b, b + n, tmp) - b;
                ans += n - pos;
                if(pos <= i) ans--;
            }
        }
        printf("%lld\n", ans >> 1);
    }
    return 0;
}

/*

2
5 5
10
0 1 2 3 4 5 6 7 8 9

*/


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值