SCU - 4437 Carries

frog has n integers a1,a2,…,an, and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines hardness h(x,y) for adding x and y the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2.

Find the total hardness adding n integers pairwise. In another word, find
∑1≤i<j≤nh(ai,aj)
.

Input
The input consists of multiple tests. For each test:

The first line contains 1 integer n (2≤n≤105). The second line contains n integers a1,a2,…,an. (0≤ai≤109).

Output
For each test, write 1 integer which denotes the total hardness.

Sample Input
2
5 5
10
0 1 2 3 4 5 6 7 8 9
Sample Output
1
20

思路:

从个位开始找一直到最大的位置,看相加大于等于10的位数平方,num就加上后面未加上的数有几个就加几。

代码:

#include<iostream>
#include <ostream>
#include<cstdio>
#include<algorithm>
#include<iomanip>
#include<cstring>
#include<string>
#include<cmath>
#define ll long long
#define dd double
#define mes(x,y) memset(x,y,sizeof(y))
using namespace std;
int a[100010],b[100010];
int main(){
	int n;
	while(cin>>n){
		for(int i=0;i<n;i++)cin>>a[i];
		ll v=1,num=0;
		for(int i=0;i<9;i++){
			v*=10;
			for(int j=0;j<n;j++)b[j]=a[j]%v;
			sort(b,b+n);
			int l=0; 
			for(int j=n-1;j>=0;j--){
				for(;l<j;l++){
					if(b[j]+b[l]>=v){
						num+=j-l;break;
					}
				}
			}
		}
		cout<<num<<endl;
	} 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GUESSERR

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值