PAT甲级 1082 Read Number in Chinese (25 分)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai
#include <iostream>
#include <algorithm>

using namespace std;
string unit[6] = {"ge", "Shi", "Bai", "Qian", "Wan", "Yi"};
string number[10] = {"ling", "yi", "er", "san", "si", "wu", "liu", "qi", "ba", "jiu"};

int main() {
    string s;
    cin >> s;
    int left = 0, right = s.length() - 1;
    if (s[0] == '-') {
        left++;
        cout << "Fu";
    }
    while (left + 4 <= right)
        right -= 4;
    while (left < s.length()) {
        bool flag = false;
        bool isPrint = false;
        while (left <= right) {
            if (left and s[left] == '0')
                flag = true;
            else {
                if (flag) {
                    cout << " ling";
                    flag = false;
                }
                if (left > 0)
                    cout << " ";
                cout << number[s[left] - '0'];
                isPrint = true;
                if (left != right)
                    cout <<" "<< unit[right - left];
            }
            left++;
        }

        if (isPrint and right != s.length() - 1)
            cout << " " << unit[(s.length() - right - 1) / 4 + 3];
        right += 4;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XdpCs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值