Commando War

Description

There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battlefield. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing in between.


Input

There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤ N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed.


Output

For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the total number of seconds counted from the start of your first briefing till the completion of all jobs.


Sample Input

3
2 5
3 2
2 1
3
3 3
4 4
5 5

0


Sample Output

Case 1: 8

Case 2: 15

这道题仍然是用贪心算法,把战士完成任务的时间按从大到小的顺序排列。下证为何如此

前提:交换任意相邻的两个任务,对这两个任务之前的任务的开始交代时间并无影响。

若我们任意交换两个任务X,Y,二者的交代时间和完成任务所需时间分别为B(X),J(X);B(Y),J(Y)。假设先X后Y,交换后Y一定提前完成,则若X的完成时间并不早于交换前Y的完成时间,那这样的交换是无意义的。这种情况可表示为:J(X)+B(X)+(J(Y)+B(Y)- J(X))<=B(Y)+J(Y)+(J(X)+B(X)- J(Y))——>J(Y)<=J(X) 

因此当X的完成任务的时间较长时是没有必要交换的。如果每两个相邻的任务适量交换则会使最终的结束时间最短。

代码如下:

#include<iostream>  
#include<stdlib.h>  
#include<cstdio> 
using namespace std;  
struct Nobe  
{  
    int x;  
    int y;  
}s[10000];  
int cmp(const void *a,const void *b)  
{  
    return (*(Nobe*)b).y-(*(Nobe*)a).y;  
}  
int main()  
{  
    int N,count=0;  
    while(scanf("%d",&N)==1&&N)  
    {  
        int finish=0,begin=0;  
        for(int i=0;i<N;i++) scanf("%d%d",&s[i].x,&s[i].y);  
        qsort(s,N,sizeof(s[0]),cmp);  
        for(int i=0;i<N;i++)  
        {  
            begin+=s[i].x;
            finish=max(finish,begin+s[i].y);
        }  
        printf("Case %d: %d\n",++count,finish);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值