【Jason's_ACM_解题报告】Rails

Rails 

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

\begin{picture}(6774,3429)(0,-10)\put(1789.500,1357.500){\arc{3645.278}{4.7247}......tFigFont{14}{16.8}{\rmdefault}{\mddefault}{\updefault}Station}}}}}\end{picture}  
The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has  N<=1000 coaches numbered in increasing order 1,2,...,N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be   a1. a2,..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.


Input
The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1,2,...,N The last line of the block contains just 0.
The last block consists of just one line containing 0.


Output 
The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.


Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0


Sample Output 
Yes
No


Yes


此题是对的简单模拟,由于对输入输出格式理解有误,迟迟不能通过。

对火车的入站出站过程进行模拟,并随时判断是否合法。A表示从A轨道驶入的第A个火车,B表示从B轨道驶出的第B个火车。

设置两个数组,a[A]为A轨道驶入的第A个火车的编号,b[B]为B轨道驶入的第B个火车的编号。显然,a[A]==A,所以省略a数组。

当前处理火车A和火车b[B]:

1.假若A==b[B],说明,火车从A轨道驶入后直接从B轨道驶出。

2.假若A<>b[B],此时又分两种情况: 1)站不空,站顶火车与b[B]相同,则站顶火车出站;

2)站为空,此时应将火车A入站,以期待将来会有一个火车A‘与b[B]相同。

3.假若A>N,而B<=N,则说明此序列不合法,否则序列合法。结束。


附代码如下:

#include<cstdio> 
#include<cstring>
#include<stack>

using namespace std;

#define CLR(x,y) (memset(x,y,sizeof(x)))
#define MAXN (1000+5)
int a[MAXN];

int main(){
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
	int n;
	while(scanf("%d",&n)==1&&n){
		CLR(a,0);
		while(scanf("%d",&a[1])==1&&a[1]){
			for(int i=2;i<=n;i++)scanf("%d",&a[i]);
			stack<int> s;
			int A=1,B=1;
			bool flag=true;
			while(B<=n){
				if(A==a[B]){
					A++;B++;
				}else if(!s.empty()&&s.top()==a[B]){
					s.pop();
					B++;
				}else if(A<=n){
					s.push(A);
					A++;
				}else{
					flag=false;
					break;
				}
			}
			if(flag)printf("Yes\n");else printf("No\n");
		}
		printf("\n");
	}

//fclose(stdout);
//fclose(stdin);	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值