【Jason's_ACM_解题报告】Fractions Again?!

Fractions Again?!

It is easy to see that for every fraction in the form 1/k (k > 0), we can always find two positive integers x and y, x >= y, such that: 
.
Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k?

Input
Input contains no more than 100 lines, each giving a value of k (0 < k <= 10000).

Output

For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.

Sample Input
2
12

Sample Output

2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24

由于x>=y。所以推倒后得y<=2*k,而且y>k。所以枚举y,并计算出x,其中x的计算公式为 x=(k*y)/(y-k)。

附代码如下:
#include<cstdio>
#include<vector>

using namespace std;

struct E{
	int x,y;
	bool operator < (const E& eq) const {return y<eq.y;}
};

int k;
vector<E> ans;

int main(){
	while(scanf("%d",&k)==1){
		ans.clear();
		for(int y=k+1;y<=2*k;y++){
			int fz=k*y,fm=y-k;
			if(fz%fm==0)ans.push_back((E){fz/fm,y});
		}
		printf("%d\n",ans.size());
		for(int i=0;i<ans.size();i++)printf("1/%d = 1/%d + 1/%d\n",k,ans[i].x,ans[i].y);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值