HDU 1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58593    Accepted Submission(s): 21518


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining

这个题目是个水题,看着就闪出用个二维数组来存入N个字符串,通过一个N一维的数组统计其中每个字符串在后面字符串的次数,最后用找出数值最大的下标……

再给输出……(不过我一开始担心会超时……我试了一下这个方法……过了,汗颜)

这里要注意的是在用gets输入字符串的时候,要用%*c跳过回车符……我第一次提交的时候没注意……WA 了……

下面是我的代码:

#include<stdio.h>
#include<string.h>
int main()
{
	char str[1002][16];
	int n,i,j,max,c[1002];
	while(scanf("%d%*c",&n)!=EOF)
	{  
		if(n==0) 
			break;
		i=0;
		while(i<n)
		{
			gets(str[i++]);//输入N个字符串

		}
		for(i=0;i<n;i++)
			c[i]=0;
		for(i=0;i<n-1;i++)
		for(j=i+1;j<n;j++)
		if(strcmp(str[i],str[j])==0)
                 c[i]++;//统计出i下标字符串的出现的次数
		for(max=0,i=1;i<n;i++)
                  if(c[i]>c[max])
			 max=i;//找出次数最多的
		  puts(str[max]);
				 

	} 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值