poj 2752 Seek the Name,Seek the Fame. 【kmp】

Time limit

2000 ms

Memory limit

65536 kB

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:对于每组数据输出一行,以递增的顺序输出,代表字符串S所有可能的前缀-后缀字符串的长度。

思路:这道题是让我们找到既能做前缀又能做后缀的子串,那么可以找 next[len] (len为字符串的长度)前的长度为next[len]的子串,这个子串一定是前缀,又由next函数的性质可以知道,这个前缀与字符串长度为next[len]的后缀是一样的,这样就找到了除字符串本身最长的满足条件的子串。同理,可以找到所有满足条件的字串的长度!

#include<iostream>
#include<cstdio>
#include<cstring>
const int maxn = 1e8+10;
using namespace std;
char s[maxn];
int next[maxn];
int ans[maxn];
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    int m=strlen(s);
    while(i<m)
    {
        if(j==-1 || s[i]==s[j])
        {
            i++,j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int main()
{
    while(~scanf("%s",s))
    {
        int len = strlen(s);
        get_next();
        ans[0] = len;
        int n=0,i=len;
        while(next[i] > 0)
        {
            ans[++n]=next[i];
            i=next[i];
        }
        for(int i=n;i>0;i--)
            printf("%d ",ans[i]);
        printf("%d\n",ans[0]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值