Lightoj 1067

Description

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15

因为数据非常的大所以用一般的暴力会超时,所以这里要用到Lusca来计算排列组合,具体代码如下:
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;
const long long MOD = 1000003;
long long fac[1000005];
long long pow(long long a, long long b, long long c)
{
    long long tmp = 1;
    while (b)
    {
        if (b & 1) tmp = (tmp*a) % c;
        a = (a*a) % c;
        b >>= 1;
    }
    return tmp;
}

void get_fac(long long p)
{
    fac[0] = 1;
    for (int i = 1;i <= p;i++)
        fac[i] = (fac[i - 1] * i) % p;
}
long long Lucas(long long n, long long m, long long p)
{
    long long tmp = 1;
    while (n && m)
    {
        long long a = n%p, b = m%p;
        if (a < b) return 0;
        tmp = (tmp * fac[a] * pow(fac[b] * fac[a - b] % p, p - 2, p)) % p;
        n /= p;
        m /= p;
    }
    return tmp;
}
int main()
{
    int n, m;
    get_fac(MOD);
    int T;
    scanf("%d", &T);
    for (int t = 1;t <= T;t++)
    {
        scanf("%d %d", &n, &m);
        int ans = Lucas(n, m, MOD);
        printf("Case %d: %d\n", t, ans);
    }
    return 0;
}
基本上就是Lusca的模板

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值