LightOJ - 1067 Combinations(逆元求组合数)

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15

 求组合数,首先套用组合数公式

阶乘提前维护一个阶乘表,除法部分用逆元。

#include<iostream>
#include<cstring>
#include<algorithm>
typedef long long ll;
using namespace std;
const int maxn=1e6+5;
const int MOD=1000003;
ll f[maxn];
void init()
{
	f[0]=1;
	for(ll i=1;i<maxn;i++)
		f[i]=(f[i-1]*i)%MOD;
}
ll exgcd(ll a,ll b,ll &x,ll &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		return a;
	}
	else
	{
		ll d=exgcd(b,a%b,y,x);
		y-=a/b*x;
		return d; 
	}
}
ll pow_mod(ll a, ll n, ll p){
    ll ret = 1;
    ll tmp = a;
    while(n) {
        if(n & 1) ret = (ret * tmp) % p;
        tmp = tmp * tmp % p;
        n >>= 1;
    }
    return ret;
}
ll inv(ll a,ll p)
{
	return pow_mod(a,p-2,p);
}
ll C(ll n,ll k,ll p)
{
	if(n==k||k==0)return 1;
	else 
	{
		ll ans1=f[k]*f[n-k]%p;
		ll ans2=inv(ans1,p);
		return (f[n]*ans2)%p;
	}
}
int main()
{
	cin.tie(0);
	ios::sync_with_stdio(false);
	init();
	int T,cas=0;
	cin>>T;
	while(T--)
	{
		ll n,k;
		cas++;
		cin>>n>>k;
		cout<<"Case "<<cas<<": "<<C(n,k,MOD)<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值