Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes
, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1
and N2
each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a
-z
} where 0-9 represent the decimal numbers 0-9, and a
-z
represent the decimal numbers 10-35. The last number radix
is the radix of N1
if tag
is 1, or of N2
if tag
is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1
= N2
is true. If the equation is impossible, print Impossible
. If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
柳神版AC代码
//柳神版AC代码
#include <iostream>
#include <cctype>
#include <algorithm>
#include <cmath>
using namespace std;
long long convert(string n, long long radix) { //转成十进制
long long sum = 0;
int index = 0, temp = 0;
for (auto it = n.rbegin(); it != n.rend(); it++) {
temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
sum += temp * pow(radix, index++);
}
return sum;
}
long long find_radix(string n, long long num) {
char it = *max_element(n.begin(), n.end());
long long low = (isdigit(it) ? it - '0': it - 'a' + 10) + 1;
long long high = max(num, low);
while (low <= high) {
long long mid = (low + high) / 2;
long long t = convert(n, mid);
if (t < 0 || t > num) high = mid - 1;
else if (t == num) return mid;
else low = mid + 1;
}
return -1;
}
int main() {
string n1, n2;
long long tag = 0, radix = 0, result_radix;
cin >> n1 >> n2 >> tag >> radix;
result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) : find_radix(n1, convert(n2, radix));
if (result_radix != -1) {
cout<<result_radix;
} else {
cout<<"Impossible";
}
return 0;
}
没找出问题所在的错误答案:(找出来了)
#include<vector>
#include<iostream>
#include <algorithm>
#include <math.h>
using namespace std;
unsigned long long GetValue(char ch){
if('0'<=ch&&ch>='9') //...注意大于号小于号..
return ch-'0';
return ch-'a'+10;
}
int main(){
string a,b;
int radix,tag;
cin>>a>>b>>tag>>radix;
unsigned long long aValue=0;
if(tag==2)
swap(a,b);
for(int i=0;i<a.length();i++)
aValue=aValue*radix+GetValue(a[i]);
unsigned long long left=0;
for(int i=0;i<b.length();i++)
left=max(left,GetValue(b[i]));
left=left+1;
unsigned long long right=aValue+1;
int result=0;
while(left<=right){
unsigned long long mid=left+right>>1;
unsigned long long check=0;
for(int i=0;i<b.length();i++)
check=check*mid+GetValue(b[i]);
if(check==aValue)
result=mid;
if(check>=aValue)
right=mid-1;
else
left=mid+1;
}
if(result!=0)
cout<<result;
else
cout<<"Impossible";
return 0;
}